Installing PyMQI 1.2 on CentOS 5.5

PyMQI 1.2 got released recently. Check the announcement here.

I was installing on my workstation which runs CentOS 5.5. I usually try to test here before putting on RHEL.

I think majority of MQ installations are still on RHEL 5.* as 6 came out recently. The default python installation is 2.4 on RHEL 5.5 and doesn’t contain the ctypes by default. This needs to be downloaded from the sourceforge download as found in the project page and install as per the instructions.

Download the pymqi 1.2 source code from the launchpad page and install it. You need gcc and also python-devel RPM packages installed as pre-requisties.

The last part which I had to do on my work station to avoid exporting LD_LIBRARY_PATH. I had to add /usr/lib64/python2.4/site-packages and /opt/mqm/lib64 and run ldconfig to avoid the missing packages error. Once done, fire up the interpreter,

[mine@tatooine ~]$ python
Python 2.4.3 (#1, Nov 11 2010, 13:30:19)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-48)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pymqi
>>> pymqi.__version__
'1.2'
>>>